Webmastersite.net
Register Log In

Multilingual display
Here are the problems with multilingual translations .

Comments on Multilingual display

milouchouchou
Forum Regular

Usergroup: Customer
Joined: Nov 05, 2006
Location: Borlo Belgique

Total Topics: 27
Total Comments: 121
Multilingual display
Posted Sep 29, 2013 - 5:10 AM:

Hello Paul

I wonder if these problems are not related to files that have been improperly transferred during updates because everything worked perfectly there are still about 1 week ????

Here are the problems with multilingual translations .

1- All titles and descriptions of the categories are translated with custom fields ( englishname , englishdescription , dutchname , dutchdescription , germanname , germandescription , spanishname , spanishdescription )

I recall that the basic scripting language is French.

I'm on the home page in French ( http://www.milouchouchou.com/articles/ ) and I click on the English language , categories and descriptions are displayed well in English.

The problem : If I click on the title " Breeds of dogs ", this link send to the " breeds-of-dogs " category ( http://www.milouchouchou.com/articles/breeds-of-dogs/ ) and obviously with the message " No such happy exists . The link you are Following Seems to Have Been incorrect "

Normally, this link should refer to " Les races de chiens " ( www.milouchouchou.com/artic...icles/les-races-de-chiens/ ) , it should go to the database, take the titles and descriptions in English and display in that language, the same for other languages.

Then if you click on a breed of dog, show this breed the requested language, but I do not know if this is because the list does not appear.

2 - For the second problem , I'll be on the list of breeds in French ( www.milouchouchou.com/artic...icles/les-races-de-chiens/ ) , I click on the race " Ariégeois " and this race appears perfectly in french .

If I click on the English language , this race is always displayed in French and with misinterpreted HTML codes ( [ fullfont style = "margin -left: 50 "] Crâne plat ou en ogive trop prononcée [/ fullfont ] . ) same for other languages.

Again, this should go to the database, take the titles and descriptions in English and display in that language, the same for other languages.

3 - For the third problem , I'll be on the list of breeds in French ( www.milouchouchou.com/artic...icles/les-races-de-chiens/ ) , I click on English and the list appears perfectly English.

If I click " Ariege hound ", the link sends to " www.milouchouchou.com/artic...ariegeois-1426-thread.html ) and the race is still displayed with the French and same codes HTML misinterpreted.

Same here, it should go to the database, take the titles and descriptions in English and display in that language, the same for other languages.

4 - Finally, the category " Les formulaires de contact " is not translated into any other language in the display, yet it is translated when I make a change in this category.

5 - Even if I put my browser in English, the site still appears in French.

I know that's a lot, but I would like the site works perfectly in 5 languages.

Cordially.
Francis
Paul
developer

Usergroup: Administrator
Joined: Dec 20, 2001
Location: Diamond Springs, California

Total Topics: 61
Total Comments: 7868
Paul
Posted Sep 30, 2013 - 11:38 AM:

Noticed that somehow your admin language template was out of date without being marked as customized. I reverted it to the default. The language editor changed a lot recently so having the old template would've caused problems when editing language.

I'll respond to the 5 items as soon as I get a chance to look into them better. For #5 did you clear all the site's cookies (the guest language preference is stored in a cookie)?

milouchouchou
Forum Regular

Usergroup: Customer
Joined: Nov 05, 2006
Location: Borlo Belgique

Total Topics: 27
Total Comments: 121
Posted Sep 30, 2013 - 12:28 PM:

Yes, I deleted all cookies, I also emptied the cache, without success.

Paul
developer

Usergroup: Administrator
Joined: Dec 20, 2001
Location: Diamond Springs, California

Total Topics: 61
Total Comments: 7868
Paul
Posted Sep 30, 2013 - 10:31 PM:

1. Fixed to always use the base language url.

2&3. Applied WSN codes to the translated versions.

Notced the next/previous article code was slowing your details page by several seconds so I removed it, you can reinsert if you really want it:

<p align="center">
<IF {PREVIOUSEXISTS}><a href="{PREVIOUSURL}">{LANG_DETAILS_PREVIOUS}</a></IF>
<IF {PREVIOUSEXISTS} and {NEXTEXISTS}> | </IF>
<IF {NEXTEXISTS}><a href="{NEXTURL}">{LANG_DETAILS_NEXT}</a></IF>
</p>

The submission history on the details page is taking several seconds too -- you might want to remove the toplist of the submitters other listings and just have a search link there.

Will try to get to 4 and 5 tomorrow.

milouchouchou
Forum Regular

Usergroup: Customer
Joined: Nov 05, 2006
Location: Borlo Belgique

Total Topics: 27
Total Comments: 121
Posted Oct 01, 2013 - 4:47 AM:

Thank you Paul

It starts to take shape.
I have this error when I want to access the list of races:

Fatal error: Maximum execution time of 30 seconds exceeded in / home/milouch1/public_html/articles/includes/commonfuncs.php on line 6315
or

Fatal error: Maximum execution time of 30 seconds exceeded in /home/milouch1/public_html/articles/classes/wsncode.php on line 135

Where do you want to replace history ( I assume you mean the switche "member status area") by an internal search? I like to keep a current presentation of articles or I need to redo the entire layout of my pages.

Cordially.
Francis

Paul
developer

Usergroup: Administrator
Joined: Dec 20, 2001
Location: Diamond Springs, California

Total Topics: 61
Total Comments: 7868
Paul
Posted Oct 01, 2013 - 8:15 PM:

This is the slow toplist I meant:
<!-- BEGIN TOPLIST -->
<CONFIG>links,time,5,descending,ownerid={LINKOWNERID}</CONFIG>
<a href="{LINKDETAILSURL}">{LINKTITLE}</a> <br >
<!-- END TOPLIST -->


The search link is already there below it. No need to remove the entire member status area, just that toplist.
Paul
developer

Usergroup: Administrator
Joined: Dec 20, 2001
Location: Diamond Springs, California

Total Topics: 61
Total Comments: 7868
Paul
Posted Oct 01, 2013 - 8:43 PM:

The big problem I'm seeing now is that the URL de-translations are killing performance, {LINKDETAILSURL} is taking half a second to parse each time instead of less than a hundredth of a second like before. I'm trying to find a way to make the URLs work without killing performance.

I see the WSN code parsing that fixed #3 is the biggest culprit.
Paul
developer

Usergroup: Administrator
Joined: Dec 20, 2001
Location: Diamond Springs, California

Total Topics: 61
Total Comments: 7868
Paul
Posted Oct 01, 2013 - 11:02 PM:

Okay, rewrote all the multilingual URL generation to be more efficient and the site at least loads now. Will look for more speed bottlenecks tomorrow.

#4 seems to have been solved in the course of the rest.
milouchouchou
Forum Regular

Usergroup: Customer
Joined: Nov 05, 2006
Location: Borlo Belgique

Total Topics: 27
Total Comments: 121
Posted Oct 02, 2013 - 2:54 AM:

Hello Paul

Congratulations for the work, it begins to work very well.

I commented out the code and the item appears in less than a second.
The translation of the categories is also resolved.
The links lead to good basic category in the chosen language.

Too bad the display of the list of items (only 12 items per page) is still a lot of time, about 7 seconds, but I'm sure you go to find a way to optimize it.

# 5 is resolved?

Very good day.
Cordially.
Francis

Paul
developer

Usergroup: Administrator
Joined: Dec 20, 2001
Location: Diamond Springs, California

Total Topics: 61
Total Comments: 7868
Paul
#10 - Quote - Permalink
Posted Oct 02, 2013 - 3:04 PM:

I've got www.milouchouchou.com/artic...icles/les-races-de-chiens/ down to around 1 second now, so you can increase the number shown per page if you want.

Haven't gotten to #5 yet, that'll be next.
Paul
developer

Usergroup: Administrator
Joined: Dec 20, 2001
Location: Diamond Springs, California

Total Topics: 61
Total Comments: 7868
Paul
#11 - Quote - Permalink
Posted Oct 02, 2013 - 7:43 PM:

As for #5, I cleared all cookies and went to http://milouchouchou.com/articles/ in Firefox. It shows me the page in English, even though French is the default language, so that's working. To get any idea of why it may not work for you, I need to know what your browser reports in its HTTP_ACCEPT_LANGUAGE header. Run this PHP code at Admin -> Misc -> Advanced -> run php and tell me what the output is:

<?php die("Language is ".$_SERVER['HTTP_ACCEPT_LANGUAGE']." and from that we decided to use ".findbestlanguage()); ?>

milouchouchou
Forum Regular

Usergroup: Customer
Joined: Nov 05, 2006
Location: Borlo Belgique

Total Topics: 27
Total Comments: 121
#12 - Quote - Permalink
Posted Oct 03, 2013 - 2:14 AM:

Hello Paul

When my browser is in French:

Language is fr, en-q = 0.8, with q = 0.5, en-us; q = 0.3 and from Abebooks web Decided to use french

When my browser is in English:

Language is en-us by q = 0.8, en; q = 0.5, en-q = 0.3 and from Abebooks web Decided to use English
But in this case, my site still appears in French.

For the rest, a big thank you for this good work, I gave a list of 40 races per page and the result is impressive:
28 total queries
This page was created in 1.88 seconds
Memory used: 18310560 (peak 19,641,984) bytes

Good day.
Cordially.
Francis

Paul
developer

Usergroup: Administrator
Joined: Dec 20, 2001
Location: Diamond Springs, California

Total Topics: 61
Total Comments: 7868
Paul
#13 - Quote - Permalink
Posted Oct 03, 2013 - 11:08 AM:

If findbestlanguage() picked English but you see French, the only explanation I can see is a cookie.
milouchouchou
Forum Regular

Usergroup: Customer
Joined: Nov 05, 2006
Location: Borlo Belgique

Total Topics: 27
Total Comments: 121
#14 - Quote - Permalink
Posted Oct 03, 2013 - 2:26 PM:

The cookies have been deleted and emptied caches.

Looking at my stats, it seems that visitors arrive at the site in the language of the browser, it is essential for them.

I tested with Opera, I arrive at the site in English if I chose this language in the browser settings.
Maybe a bad configuration of my Firefox.

Again thank you for your work, I really appreciate your service to your scripts.

Cordially.
Francis

Search thread for
Download thread as
  • 0/5
  • 1
  • 2
  • 3
  • 4
  • 5



Sorry, you don't have permission to post posts. Log in, or register if you haven't yet.