Webmastersite.net
Register Log In

Cannot extract data from the database

Comments on Cannot extract data from the database

babrees
Expert

Usergroup: Customer
Joined: Aug 19, 2005
Location: England

Total Topics: 391
Total Comments: 1303
babrees
Posted Oct 09, 2008 - 6:18 AM:

HELP!

I have two sites down - both are showing the message...
Cannot extract data from the database.
It seems that although we established a database connection we aren't able to access the database itself. It could be that the database is down (ask your web host about this), or that the mysql user doesn't have proper permissions to acces the database. MySQL returns this error:
WSN Links 4.1.49



http://www.bedtimebedcentre.co.uk is running v. 4.1.49

http://www.wineloversclub.co.uk us running v.4.1.57

This happened before on a site but I didn't bother too much because I was upgrading it from 4.1 series to 5 and basically starting afresh with it. Although I did contact my host who said he could see nothing wrong with the database or site so believed it must have been the script.

Not sure when the first site above was last updated as client does that.

Second site has just been sitting there for a while, not worked on.

[UPDATE]

At the same time as posting here I also contact my host support. Their reply...

There were corrupt tables in the db for both sites.
I have repaired them, but it now gives a different error message.

The dbs now pass all consistency checks, but the app is still reporting its
unable to read the data.

It does not use the regular php mysql libs, and instead uses some 3rd party
abstraction layer.

I would suggest you update that library to see if that resolves the issue.



This makes no sense to me cool Can you help Paul? I have no idea how the tables became corrupted in the first place
babrees
Expert

Usergroup: Customer
Joined: Aug 19, 2005
Location: England

Total Topics: 391
Total Comments: 1303
babrees
Posted Oct 09, 2008 - 7:50 AM:

Further update....

Through PHPMyAdmin I restored the backup and the sites seem to be working ok now. But I am concerned if it happens again.
Paul
developer

Usergroup: Administrator
Joined: Dec 20, 2001
Location: Diamond Springs, California

Total Topics: 61
Total Comments: 7868
Paul
Posted Oct 10, 2008 - 5:58 AM:

There are no third party abstraction layers involved. mysqli isn't a third party abstraction layer, it's a native part of PHP. Maybe your host is only supporting the mysql extension, so you could edit config.php to mysql instead of mysqli -- or inform them that mysqli is the native PHP mysql interface for mysql 4.1+ and should be available. In fact it automatically reverts if the functions aren't available, so they'd have to have the mysqli function installed but non-functional to get the error.

If it gave the same error after the corruption fix, that means it wasn't able to load the database. Lack up mysqli support is the only reason other than corruption I can think of without being given the chance to look at it.
Search thread for
Download thread as
  • 0/5
  • 1
  • 2
  • 3
  • 4
  • 5



Sorry, you don't have permission to post posts. Log in, or register if you haven't yet.