Webmastersite.net
Register Log In

Filtering by state
can't get it to work...

Comments on Filtering by state

Animal
Member

Usergroup: Customer
Joined: Jan 08, 2005

Total Topics: 6
Total Comments: 12
Animal
Posted Mar 01, 2005 - 8:57 AM:

Can someone tell me what I'm doing wrong? I'm trying to follow the information on scripts.webmastersite.net/w...nks/wsnmanual/articles/201 (manual)

I've tried to filter my listings by state. {LINKLSTATE} but need to give the user the choice from a drop down.

I tried to add a sample of my code but the forum keeps changing it, so I've had to put a : where there should be a = after form action.

<form action:"index.php?action=displaycat&catid=20&filter=lstate" method="post">
Show Only Listings in this
<select name="filtervalue" class="body">
<option value="" selected>State</option>
<option value="CA">California</option>
<option value="CO">Colorado</option>
</SELECT>
<input type="submit" value="Filter" class="button">
</form>

I'm sure it's something simple, but I can't seem to find it.
Paul
developer

Usergroup: Administrator
Joined: Dec 20, 2001
Location: Diamond Springs, California

Total Topics: 61
Total Comments: 7867
Paul
Posted Mar 03, 2005 - 12:08 AM:

Filtering does >= and optionally <=. There isn't a filtering option for = or string comparison that I recall, so that'd be why it doesn't work.

It seems to me that a simple search, not needing to involve refinement etc as you were before, would be fine for showing results in a category for a state. As the manual entry says, just reconstruct what you'd type on the advanced search page changing the form variables into url variables.
Search thread for
Download thread as
  • 0/5
  • 1
  • 2
  • 3
  • 4
  • 5



This thread is closed, so you cannot post a reply.