Webmastersite.net
Register Log In

Installation failed. Deleting.
No joy using autosetup.php

Comments on Installation failed. Deleting.

digiguy
Experienced

Usergroup: Customer
Joined: Aug 04, 2007

Total Topics: 16
Total Comments: 60
digiguy
Posted Nov 22, 2008 - 1:37 PM:

Have downloaded autosetup.php and uploaded to my server and kept it with 644 default permission.
Ran the script and first ran into ulink(bla, blah) errors and then placed @ symbol in front to over come that.

Basically I use all as defaults and the following:

Use all as default for URL to install I use http://www.xyz.com/shops
and for filepath I use /home86a/sub001/sc47508-LKJR/www/shops/

After clicking on INSTALL I am keep (after about 1 minute) end up with the following message:

Installation failed. Deleting. shocked

Well, that's not a lot of clue to what may have gone wrong.

Now I wonder if there's a debug option to run autosetup.php to figure out which bit fails to get this script installed.

Thanks, Joe



Paul
developer

Usergroup: Administrator
Joined: Dec 20, 2001
Location: Diamond Springs, California

Total Topics: 61
Total Comments: 7868
Paul
Posted Nov 22, 2008 - 11:46 PM:

Ran the script and first ran into ulink(bla, blah) errors and then placed @ symbol in front to over come that.

Please don't ever do that. You need to tell me what those messages were instead of hiding them.

Consider requesting free installation: scripts.webmastersite.net/w...ustom=yes&TID=installation
digiguy
Experienced

Usergroup: Customer
Joined: Aug 04, 2007

Total Topics: 16
Total Comments: 60
digiguy
Posted Nov 23, 2008 - 4:51 PM:

Hi Paul,

Long time no speak ... I think last was around 2004?
Well, under Internet Explorer 8 beta & FireFox 3 I ran autosetup.php from root and landed with:

www.xyz.com/autosetup.php?filled=1

Error generated:

Installation failed. Deleting.

Warning: unlink(/home86a/sub001/sc47508-LKJR/www/shops//config.php) [function.unlink]: No such file or directory in /mounted-storage/home86a/sub001/sc47508-LKJR/www/autosetup.p hp on line 428

I will opt in for your installation offer and keep fingers crossed.

It would be great if it was possible to install the script so the links would form the root ie.:

xyz.com/travel/
then sub CAT
xyz.com/travel/insurance/

maybe using some mod rewrite later...

Thanks, Joe
Paul
developer

Usergroup: Administrator
Joined: Dec 20, 2001
Location: Diamond Springs, California

Total Topics: 61
Total Comments: 7868
Paul
Posted Nov 24, 2008 - 3:05 AM:

I can't tell quite what the issue issue was still, except that the very same call to setup.php which worked when I copied it myself didn't work when the script called it for you. This suggests perhaps a CURL issue, where CURL is installed by somehow fails sometimes... but other URL-loading functions seem to be working, so that doesn't seem like it's the case. Oh well, it's installed.

It would be great if it was possible to install the script so the links would form the root

Of course you can.
digiguy
Experienced

Usergroup: Customer
Joined: Aug 04, 2007

Total Topics: 16
Total Comments: 60
digiguy
Posted Nov 24, 2008 - 3:22 PM:

Thank you Paul for helping me out with the install, you're a legend.
Everything is the way I wanted it and better, perfect.

One more tiny question if I may.
I would like to use XLS to pre-fill Title, Description, URL, etc. and upload all at once with pre-defined CATs.
Sorry if you hav covered this topic else where and I promise to look when I get a tiny window of spare time...it's not so easy now to get into 'deep' work with my 2year old keep trying to do all the scripting on my laptop for me... :-)

Thanks, Joe
Paul
developer

Usergroup: Administrator
Joined: Dec 20, 2001
Location: Diamond Springs, California

Total Topics: 61
Total Comments: 7868
Paul
Posted Nov 28, 2008 - 1:45 PM:

Save as a CSV or TSV, then use the flat-file import.
Search thread for
Download thread as
  • 0/5
  • 1
  • 2
  • 3
  • 4
  • 5



Sorry, you don't have permission to post posts. Log in, or register if you haven't yet.