Webmastersite.net
Register Log In

6.0 Beta release

Comments on 6.0 Beta release

Paul
developer

Usergroup: Administrator
Joined: Dec 20, 2001
Location: Diamond Springs, California

Total Topics: 61
Total Comments: 7862
Paul
6
Posted Aug 31, 2010 - 10:45 am:

I've placed a download link in the customer downloads area.

Please note that there will be an upgrade fee for the 6.0.0 final release, but not for the betas.

Upgrade procedure (please use a clone, Admin -> Misc -> Clone):
1. Upgrade to the latest 5.1 release.
2. Go to /admin/autoupgrade.php?switchseries=1&keeptemplates=1 (or remove keeptemplates=1 to automatically overwrite templates)
3. You're done.


Known bugs:
- wsn gallery comment subscriptions not working according to bittercrank. didn't see the option even even showing.

Essential planned features:
- ratings+comments option to include a capatcha for guests and usergroup permissions so that the reviews can be held for validation

Non-essential:
- admin panel spot to set the requested linking code (linking code is given in suggest.tpl, showvotecode.tpl and the language item suggestlink_cantfindrecip). it should be a language item since it'd vary by language, but i can allow editing on the link settings page (put all languages there?).
- forced ignores -- disallow a poster from reading or replying to another poster. that'd use a member field forcedignore. posts would be invisible. postreply would ensure they're not quoting the person.
- highlight friend posts in-thread with additional style class

6.0 feature list (x indicates it's sufficiently tested for release):
x- Reduced queries and increased speed, especially for scenarios where numerous switches are off.
x- Lightbox attachment galleries.
x- A flash-based multi-file uploader with progress bars. Uploading numerous large files at once is now a breeze.
x- Admin option to choose which buttons are available in WYSIWYG standard and basic modes.
x- Attached images are now listed in google sitemaps to improve your google image search performance.
x- Added filter search options to the email log page.
x- Banning date and reason now in profile.
x- Separated the admin-only options under a special heading on submit/edit pages for clarity.
x- Added facebook "like" button to improve your social network marketing.
x- Standard edit/deletion reason options in a selector for moderators.
x- When the proprietary geoip database is loaded, it's now used to show admins the city a poster lives in.
x- Added miniature avatars in IM and shoutbox (plus on threads in WSN Forum).
x- Online indicator and IM button by posts, and general rejiggering of the postbit.
x- Updated to google maps API v3 and simplified the template code.
x- Added an option to preview edits of private messages.
x- Enabled conditionals in IM chat line.
x- Added type selector to the bulk edit listings admin page.
x- Prevented submission of non-html in the category header insertion boxes (auto-guesses appropriate meta tag to use).
x- The edit option on the details page now returns to listing details instead of to category after finishing.
x- In WSN Forum, added a warning prompt when moving a thread another moderator has already moved.
x- Submission times now displayed on validation page.
x- Color coding for usergroups on manage usergroups page.
x- Added 'can view member list' and 'can view member profiles' usergroup permissions.
- Updated WYSIWYG to the latest CKEditor, added background color for it to the stylesheet, and incorporated smilies into it.
- Options (size etc) for shopping cart. Just use <input type="hidden" name="cartoption1label" value="Size" /><select name="cartoption1">...size options...</select> where you could add an unlimited number of options by changing 1 to 2 or 3 etc. This should make wsn suitable as a shopping site. Note: quantity could be a standard option to test with.
- Redid sponsorship backend to be more future-proof. [paypal.php (well, inc/sponsorcommon.php) is broken on PF at last check]
- Listing description length can now be altered by sponsorship. [NEEDS MUCH TESTING!]
- A more powerful backups system, with staggered automated backups over two weeks and download/restore options on the backups page. [Currently broken on PF!]
- Member ratings now default to percentage approval, with visual bar by posts illustrating. [bar seemed off visually i think]
- An option to delete a custom template in the template editor.
- Ability to pass &returnto={CURRENTURLENCODED} to the submit or edit pages to be returned after submitting/editing/deleting.
- Custom file attachment fields for calendar events.
- In WSN Forum, when somebody edits their first post title it now automatically changes the topic title too.

Edited by Paul on Sep 28, 2010 - 2:19 pm
babrees
Expert

Usergroup: Customer
Joined: Aug 19, 2005
Location: England

Total Topics: 391
Total Comments: 1303
babrees
Posted Sep 05, 2010 - 3:09 am:
Is there a list of what's new in this release?

First thing that hits me is admin area - the font in the menu headers is unreadable for me.

Cheers
Jill
Paul
developer

Usergroup: Administrator
Joined: Dec 20, 2001
Location: Diamond Springs, California

Total Topics: 61
Total Comments: 7862
Paul
Posted Sep 06, 2010 - 2:25 am:
Edited feature list, upgrade procedure and other stuff into the opening post.

Does this admin panel look like the attached to you or is it something different? I guess it is a poor font choice, will change it...

Attached Files:
babrees
Expert

Usergroup: Customer
Joined: Aug 19, 2005
Location: England

Total Topics: 391
Total Comments: 1303
babrees
Posted Sep 06, 2010 - 3:21 am:
No, admin panel is worse than that, chunky and blurry. Yes, please, stick with arial smiling face

Thanks for the list.
babrees
Expert

Usergroup: Customer
Joined: Aug 19, 2005
Location: England

Total Topics: 391
Total Comments: 1303
babrees
Posted Sep 12, 2010 - 8:54 pm:
In managing the usergroups the new section "Member Accounts" isn't available for guests. I have a site where guests are allowed to view the member list and member profiles.

Edited by babrees on Sep 12, 2010 - 11:07 pm
babrees
Expert

Usergroup: Customer
Joined: Aug 19, 2005
Location: England

Total Topics: 391
Total Comments: 1303
babrees
Posted Sep 13, 2010 - 12:30 am:
I'm another one who can't see the WYSIWYG editor. Running FF 3.6.6 on Windows XP Pro, SP3

On the memberlist.tpl, the header columns have a closing span but no opening.

Edited by babrees on Sep 13, 2010 - 1:56 am
Paul
developer

Usergroup: Administrator
Joined: Dec 20, 2001
Location: Diamond Springs, California

Total Topics: 61
Total Comments: 7862
Paul
Posted Sep 13, 2010 - 4:28 pm:
Checked XP Home Firefox 3.6.9, no problems there for me. Refreshing doesn't help?
babrees
Expert

Usergroup: Customer
Joined: Aug 19, 2005
Location: England

Total Topics: 391
Total Comments: 1303
babrees
Posted Sep 13, 2010 - 11:30 pm:
nope - refreshing does not show the WYSISYG.

hmm, FF 3.6.9 ? My version is 3.6.6 and it says there are no updates. I see that on their site it is 3.6.9 so shall manually download that



(edit) Upgraded firefox to 3.6.9 - still can't see the editor. I have also tried on an upgraded version and a fresh install.

Edited by babrees on Sep 14, 2010 - 12:52 am
Paul
developer

Usergroup: Administrator
Joined: Dec 20, 2001
Location: Diamond Springs, California

Total Topics: 61
Total Comments: 7862
Paul
Posted Sep 14, 2010 - 2:19 pm:
Okay, let's try to narrow this down. Can you see this? If not, how about this?
babrees
Expert

Usergroup: Customer
Joined: Aug 19, 2005
Location: England

Total Topics: 391
Total Comments: 1303
babrees
#10 - Quote - Permalink
Posted Sep 14, 2010 - 9:37 pm:
Yes, I can see both of those. However, the first one only has 6 editorial icons - Bold, Italic, number outline, bullets and links; whilst the second one appears to have all icons, covering 3 rows.
Paul
developer

Usergroup: Administrator
Joined: Dec 20, 2001
Location: Diamond Springs, California

Total Topics: 61
Total Comments: 7862
Paul
#11 - Quote - Permalink
Posted Sep 16, 2010 - 2:51 pm:
Must be something in WSN pages conflicting somehow for certain people and not others, but not a ckeditor bug then. I'm going to take apart a page piece by piece to try to see where it might start working for you. Tell me which of these work:

#1: http://scripts.webmastersite.net/test/cktest1.html (complete page -- I assume this doesn't work for you?)
#2: http://scripts.webmastersite.net/test/cktest2.html (post-ckeditor javascript removed)
#3: http://scripts.webmastersite.net/test/cktest3.html (all non-ckeditor javascript removed)
#4: http://scripts.webmastersite.net/test/cktest4.html (simplest possible page)
tcqgryphon
Beginner

Usergroup: Customer
Joined: Nov 16, 2004

Total Topics: 2
Total Comments: 3
#12 - Quote - Permalink
Posted Sep 16, 2010 - 7:59 pm:
Would anyone be interested in a new admin design / CSS? Paul does great programming work but I find that I've had to regroup and redesign the admin section with tool-tips and a few help files for my clients from time to time... would this be of interest to anyone else? I'm thinking of providing an zip for download but I can't promise much support right now.

Paul
developer

Usergroup: Administrator
Joined: Dec 20, 2001
Location: Diamond Springs, California

Total Topics: 61
Total Comments: 7862
Paul
#13 - Quote - Permalink
Posted Sep 17, 2010 - 10:56 pm:
What sort of things do you need tooltips on, and what do you have in mind regarding the other changes?
babrees
Expert

Usergroup: Customer
Joined: Aug 19, 2005
Location: England

Total Topics: 391
Total Comments: 1303
babrees
#14 - Quote - Permalink
Posted Sep 17, 2010 - 11:29 pm:
hmm, that's strange, I replied but it's not posted. Wonder if I forgot to hit submit as I did go off and test something else!!

Anyway, Paul. I can't see any of those tests. Not even the simplest, which is a blank page for me



Jill
babrees
Expert

Usergroup: Customer
Joined: Aug 19, 2005
Location: England

Total Topics: 391
Total Comments: 1303
babrees
#15 - Quote - Permalink
Posted Sep 18, 2010 - 2:28 am:
I upgraded a site. When I added a new category I got the error...

Fatal error: Call to a member function replacements() on a non-object in /home/shoptodr/public_html/directory/includes/addcat.php on line 203

However, when I went back into the site it had made the category and everything appears to be ok (at the moment!)
Search thread for
Download thread as
  • 0/5
  • 1
  • 2
  • 3
  • 4
  • 5



Sorry, you don't have permission to post posts. Log in, or register if you haven't yet.